Technical Bulletin: Files in Use message when installing SaaSGrid SDK

Initial publication: July 18, 2011
Last reviewed on: July 18, 2011
Last updated on: July 18, 2011

While installing the SaaSGrid SDK when a previous version has been installed, the installation process may inappropriately prompt the user to "kill" processes that correspond to SaaSGrid itself. 

Symptoms

  • A previous version of the SaaSGrid SDK has been installed (Version 2.0.0 or Later)
  • The SaaSGrid Local API Host service (part of the SaaSGrid SDK) is running
  • SaaSGrid Express is installed and running on the same machine (either newly installed or from a previous install)
  • When initiating an install of the new SaaSGrid SDK, two dialog boxes appear in succession. The first dialog box asks to stop the SaaSGrid Local API Host. Upon stopping this service and clicking Retry, the second dialog box asks to stop two or more processes, which are named only with the PID. These PIDs, according to Task Manager, correspond to services that make up SaaSGrid Express.

The following screenshot is an example of the first dialog box:

The following screenshot illustrates the second dialog box along with a screenshot of Task Manager:

Resolution

This issue has been verified and is currently outstanding. This problem may be resolved in a future version of SaaSGrid. 

Is there a Manual Workaround?

To work around this issue, follow these steps:

  1. Cancel the SDK installation (if you are launching the SDK installation from the SaaSGrid Express installer, you can leave the SaaSGrid Express installer open)
  2. Manually uninstall the SDK
  3. Re-attempt the SDK installation. So long as the SaaSGrid Local API Host service is not running, the SaaSGrid SDK installer does not flag the other SaaSGrid processes as needing to be closed.

Applicable Component(s):

  • SaaSGrid SDK

Affected Version(s):

  • 2.0.x (all versions)
  • 2.1.x (all versions)
  • 2.5.x (all versions)

2115